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Nlag Net

Installation MagIC Net 2.x

1 Minimum system requirements

Operating system

RAM

Memory

Serial ports

USB ports

Screen

The windows user must have administrator rights in order to be able to install

32 bit version of:

= Windows 2000 SP4

= Windows XP Professional SP2

= Windows Vista Business / Enterprise / Ultimate
= Windows 7 Professional / Ultimate / Enterprise

Windows 2000 / Windows XP: 1 GB
Windows Vista, Windows 7: 2 GB
Program: 1 GB

Data: 2 GB

for devices with RS-232 interface
for devices with USB interface

Resolution 1024 x 768

the MagIC Net software.

Additional requirements for the MagIC Net server:

Operating system

Network
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32 bit version of:

=  Windows 2000 SP4

= Windows XP Professional SP2

= Windows Vista Business / Enterprise / Ultimate
=  Windows 7 Professional / Ultimate / Enterprise
= Windows 2000 Server

= Windows Server 2003

= Windows Server 2008

= Windows Server 2008 R2

10 Mbit/s, stable and permanent

Communication via TCP/IP



Caution

During a determination data loss may occur when the PC switches over to the
standby mode. In the energy settings of the operating system the standby
mode should therefore be deactivated.

2 Single workplace installation

With the single workplace version MaglC Net Basic, MaglC Net Compact or
MagIC Net Professional the MagIC Net client as well as the server will be
installed on your computer.

1 Oninserting the CD into the drive of your computer the installation will be
started automatically. If this option is deactivated on your computer, double
click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

2 After having read the license agreement for MagIC Net and accepting it
with [Yes] a window will appear where you can enter the license code.

3 Enter the license code for MaglC Net Basic, MaglC Net Compact or
MagIC Net Professional and click on [Next].

Metrohm MagIC Net 2.0 Setup =] |
License code
Flease type in vour icense code. n Mel’rohm

License code [IC20 - | = | |

InstallZhield

ﬂ Note

If you have entered the license code of an update license, then the license
code of the previous full version will additionally be requested.

< Back | Mext » I Cancel
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Metrohm MagIC Net 2.0 Setup =] |

License code

Flease type in vour icense code. n MetrOhm

License code IC20  -[ 0123 -[4567 -|go;m1  -[2345  -[67&9

@ The licence code is valid only for a program update,
Flease enter the licence code of the previous full werzsion.

License code |IC] | | -| | |

InstallShield

< Back | Mext » I Cancel |

4 Now enter the target folder for the MagIC Net installation and confirm
with [Next].

5 In the dialog window Additional installation information you can
define the paths for the database and backup files:

Metrohm MagIC Net 2.0 Setup =] |

Additional installation information.

Flease enter the necessary information n MeI‘rOhm

far the operation,

@ Every user needs read/write rightz for the specified directories!

[Databaze path IC:'\F'rogram FileztMetrohmibaglC MethData |

Default backup path |C:\Pragram Files'Metrohm'tMaglC MetsB ackup |

advanced... |
< Back | Mext » I Cancel |

InstallShield

The default paths differ in Windows Vista and Windows 2000 or Win-
dows XP.

Under [Advanced...] it is possible to change the ports MaglC Net uses to
communicate with the database and administration server. If the ports are
used already, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next].

6 Follow the instructions of the program until the following message appears:
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Metrohm MagIC Net 2.0 Setup =]

- If wou use a firewall program please check its settings.
\EJ) MaglC Met uses the Following ports:
7001, 7002, 5745, 5746

This message points out which ports MaglC Net uses. Write down these
ports and inform your system administrator in case MagIC Net is not able
to connect to the database. Confirm the message with [OK].

As soon as the copying procedure has been finished you can set further
workplace settings:

Metrohm MagIC Net 2.0 Setup a8 x|
Workplace settings
Flease zet your client ID and your n Mel’rohm

preferred language.

Client 1D |X2]

= This client 1D must exist i e curent
[dag|C et spstem.

Language I English j

InstallShield

< Back | Meut = I Cancel |

The option "The client ID must exist in the current MagIC Net sys-
tem." is only selectable, if a database from a previous installation exists on
your computer or if you want to connect to a database server which has
already been installed on another computer.

If you activate this option MaglC Net checks whether the identifier you
have entered exists in the database. If this is true the identifier and all asso-
ciated settings will be adopted. With this option a renewed installation of
a client is much easier.

Click on [Next]. If the database ports are not available, an appropriate error
message will appear and the installation will be canceled. In this case, check
your server and firewall settings before installing the program again.

At the end of the installation the file info.txt will be created which contains
all relevant information concerning your current MaglC Net installation.
Save this file on your hard disk in case of need in future and print it (add to
|Q). Complete the installation with [Finish].

An InstallLog file with a list of all files having been copied to your computer
and with a confirmation for a successful installation is saved in the

MagIC Net installation folder (default: C:\Program Files\Metrohm

\MaglC Net) under bin\InstallLog.
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3 Client/Server installation
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With the MagIC Net Multi version (multiple workplace version with 3 licenses)
you can select during the installation whether you want to install a MaglC Net
client or the MagIC Net client plus server on your computer.

If you only want to install a MaglIC Net client on your computer, in advance a
server the client will be connected to must have been installed on another com-
puter.

1 Oninserting the CD into the drive of your computer the installation will be
started automatically. If this option is deactivated on your computer, double
click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

2 After having read the license agreement for MagIC Net and accepting it
with [Yes] a window will appear where you can enter the license code.

3 Enter the license code for MaglC Net multi and click on [Next].

Metrohm MagIC Net 2.0 Setup =] |
License code
Flease type in vour icense code. n Mel’rohm

License code [IC20 - | . | |

InstallShield

If you have entered the license code of an update license, then the license
code of the previous full version will additionally be requested.

< Back | Mext » I Cancel




Metrohm MagIC Net 2.0 Setup al x|

License code

Flease type in vour icense code. n MetrOhm

License code JIC20  -[ 0123 -[4567 -|gom1  -[2345 -[67&9

@ The licence code is valid only for a program update,
Flease enter the licence code of the previous full werzion.

License code [IC] | | -| | |

InstallShield

< Back | Mext » I Cancel |

4 Now enter the target folder for the MagIC Net installation and confirm
with [Next].

5 The dialog window Additional installation information appears where
you can select whether you want to install a client or the server:

Metrohm MagIC Net 2.0 Setup al x|
Additional installation information.
Flease enter the necessary information n MetrOhm

for the operation,

¥ Clignt/Server

@ Every user needs readAwrite rights for the specified directories!

[atabaze path |C:'\F'rogram FilestMetrohmihaglC MethData I

Diefault backup path |C:\Program Files'Metrohm'MaglC NetsBackup |
™ Clignt

Sefver | |

Advanced... |
< Back | Mext » I Cancel |

InstallShield

The option workplace installs the client and the database server on your
computer. Select this option if your computer will be used as server.

With workplace only the client will be installed and with oo you have to
select the database server (has to be installed in advance!) to which you
want to connect. The network server name or the IP address are accepted.

Under [Advanced...] it is possible to change the ports MaglC Net uses to
communicate with the database and administration server. If the ports are
used already, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next].
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6 All further installation steps correspond to those of the single workplace
installation on from point 6.

4 Modify / repair / remove installation and upgrade

license
In order to carry out modifications on the current MagIC Net installation start
the file setup.exe on the installation CD or click on Metrohm MagIC Net under
Control Panel » Software. Then select Change/Remove.
a x
Welcome
todify, repair, update, or remove the program. n Me"rohm
‘Welcome to the MaglC Met Setup Maintenance program. This program lets you modify the
current installation. Click one of the options belaw.
i Modiy
ﬁ Select new program features to add or select currently installed features to
TEMOE.
= Repair/Update
@ Reinztall all program features ingtalled by the previous setup.
" License upgrade
= Mew licenze
il
" FRemove
Remove all installed features.
|mstallShisa
< Back | Memt > I Cancel
Modify

With this option you can change the paths to the database and backup files and
set the ports which MagIC Net uses for communication. With the

MagIC Net Multi version you can additionally change the path to the database
server.

If the database path is changed, the existing databases are automatically copied
to the new location.

Repair/Update the program

With this option you can repair an existing defective installation or update an
older installation.

= Repair installation
In case of a defective MagIC Net installation because e.g. a DLL file is missing
or a program file has been deleted by mistake, MaglC Net can be repaired
with this option.

= Update installation
In case an older version of MagIC Net is installed, it will be updated to the
new version of MagIC Net, see Program update with MaglC Net Compact/
Professional or Program update with MaglC Net Multi.

8.102.8018EN



License upgrade

Remove

sional

Caution

During updating older MaglC Net versions to MaglC Net 2.x the databases will
be converted to the new version. Depending on the size of the database, this
can take some time. For each database a progress bar is displayed which
informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long as the
conversion runs!

A direct upgrade of your current installation to a MagIC Net version with addi-
tional features is possible. The following upgrade paths are possible:

= MagIC Net Compact to

MagIC Net Professional or MagIC Net Multi
= MagIC Net Professional to

MagIC Net Multi

In order to do this enter your new license code in the next dialog window.

This option removes your MagIC Net installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data etc.) will
remain on your hard disk.

Program update with MagIC Net Compact/Profes-

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically updated
for further use with MaglC Net Compact/Professional.

The files in the database and backup directory will be retained when updating
the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. . The files in these directories not having been over-
written by the update will be deleted. The deleted files are listed in the
InstallLog.

1 Save the configuration database into an external directory using the backup
function of MagIC Net. In the program part Configuration, select the
menu item File » Save » Manually. Select the Backup directory, enter

8.102.8018EN
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a name for the backup file and click on [Start]. The backup is carried out
automatically. It is recommended to copy the backup file to CD/DVD.

If desired, export the methods in addition to the automatic backup with the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. It is recommen-
ded to copy the exported methods to CD/DVD.

Save all determination databases created by yourself into an external direc-
tory using the backup function of MagIC Net. In the program part
Database, select the menu item File » Database manager.... Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is carried
out automatically. It is recommended to copy the backup file to CD/DVD.

Save further files created by yourself in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

Close MagIC Net. Insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next].

Metrohm MagIC Net 2.0 Setup =] |
Welcome
Modify, repair, update, or remove the program. n Me"rohm

“Welcome to the MaglC Met Setup Maintenance program. This program lets you modify the
current inztallation. Click one of the options below.

= Modify

ﬁ Select hew progran features to add or select currently installed features to
TEMovE.

{* Repair/lpdate
ﬁ Reinstall all program features inztalled by the previous zetup.

" License upgrade

= MHew licenze
T

= Femove
Remove all installed features.

InstallShiea

< Back | Mext » I Cancel |

6 Enter the update license code for MaglC Net Compact or MagIC Net

Professional and click on [Next].



Metrohm MagIC Net 2.0 Setup al x|

License code

Flease type in vour icense code. n Metmhm

License code [IC20 - | . | |

InstallShield

< Back | Mext » I Cancel

7 @ Caution

During updating older MaglC Net versions to MaglC Net 2.x the databa-
ses will be converted to the new version. Depending on the size of the
database, this can take some time. For each database a progress bar is
displayed which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion runs!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation for a successful installation is saved in the
MagIC Net installation folder (default: C:\Program Files\Metrohm
\MagIC Net) under bin\InstallLog.

6 Program update with MagIC Net Multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the sever are automatically updated for further use with

MagIC Net Multi.

The files in the database and backup directory will be retained when updating
the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories not having been overwritten
by the update will be deleted. The deleted files are listed in the InstallLog.

10 8.102.8018EN



1 Make sure MaglC Net Multi is closed on all clients.

ﬂ Note

In the subdirectory bin of the MagIC Net installation there is the appli-
cation Clients.exe with which all clients and their status can be dis-
played.

2 Open MagIC Net Multi on the server and save the configuration database
into an external directory using the backup function of MagIC Net. In the
program part Configuration, select the menu item File » Save » Man-
ually. Select the Backup directory, enter a name for the backup file and
click on [Start]. The backup is carried out automatically. It is recommended
to copy the backup file to CD/DVD.

3 If desired, export the methods in addition to the automatic backup with the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. It is recommen-
ded to copy the exported methods to CD/DVD.

4 Save all determination databases existing on the server into an external
directory using the backup function of MagIC Net. In the program part
Database, select the menu item File » Database manager.... Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is carried
out automatically. It is recommended to copy the backup file to CD/DVD.

5 Save further files in the installation directory (e.g. export files) into an exter-
nal directory or to CD/DVD.

6 Update server

Close MagIC Net Multi on the server and on all clients. Insert the instal-
lation CD on the server and double click the file setup.exe. Then select
Repair/Update and click on [Next].

8.102.8018EN 11



Metrohm MagIC Net 2.0 Setup al x|

Welcome

Modify, repair. update, or remaove the program. n MetrOhm

Welcome to the MaglC Net Setup Maintenance program. This program lets you modify the
current inzstallation. Click one of the options below.

= Modify

ﬁ Select hew program features to add or select currently installed features to
TEmove.

% Repair/Update
ﬁ Reinstall all pragrarn features installed by the previous setup.

" License upgrade

= Mew licenze
|
"~ Fiemave
Remove all installed features.
InstallShiea

< Back | Mext » I Cancel |

Enter the update license code for MaglC Net Multi and click on [Next].
8 x

License code

Flease type in your icenze code. n MetrOhm

License code [IC20 - | - | |

InstallShield

< Back | Meut » I Cancel

The update of MagIC Net Multi consists of the server license and three
client licenses. If an existing installation contains additional licenses, these
will be deleted.

Click on [OK] in the corresponding message in order to continue the instal-
lation.
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10

11

Caution

During updating older MaglC Net versions to MaglC Net 2.x the databa-
ses will be converted to the new version. Depending on the size of the
database, this can take some time. For each database a progress bar is
displayed which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion runs!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to the server
and with a confirmation for a successful installation is saved in the
MaglIC Net installation folder (default: C:\Program Files\Metrohm
\MagIC Net) under bin\InstallLog.

In case additional licenses have been removed during the server update, of
if further additional licenses are to be added, the Administrator can enter
them in MagIC Net (dialog: Configuration » Tools » Program admin-
istration » Licenses > Add licenses).

Update clients

For each client, insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next]. Complete the
installation with [Finish].

In order to facilitate updating many clients, the installation can be copied
from the CD to a writeable medium and the file magic_init.ini can be
modified. There, user-defined parameters (license code, installation path,
server name, ...) for the installation can be set in order one will only have
to click through the installation.

An UpdateLog file with a list of all files having been copied to the client
computer and with a confirmation for a successful installation is saved in
the MagIC Net installation folder (default: C:\Program Files\Metrohm
\MaglC Net) under bin\InstallLog.
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